Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
USB-Netzwerk funktioniert!
05-31-2011, 12:48 PM
Post: #1
USB-Netzwerk funktioniert!
Moin!

Bevor jetzt jemand ganz aufgeregt wird: Es geht um einen allerersten Test ohne jegliche Aussagekraft in Bezug auf Nützlichkeit, Nebenwirkungen oder sonst irgendetwas. Mein Antrieb war zunächst einmal einfach Neugier.
Mit der Hilfe von Bittor aus dem spanischen Forum ist es mir gelungen, (zumindest dem Prinzip nach) funktionierende Module für ein USB-Netzwerk zu kompilieren und per insmod in die spanische FW meiner M740AV einzufügen. Dann habe ich die Box per USB-Kabel mit einer Fritzbox SL verbunden, die einen entsprechenden USB-Device-Anschluss hat (vgl. http://www.zebradem.com/wiki/images/8/81...SL-1.png). Vorsicht: Die zum Anschluss von Druckern, Festplatten etc. gedachten USB-Host-Anschlüsse neuerer Fritzboxen sind nicht gemeint, bei denen wäre mindestens ein USB Host-to-Host-Kabel nötig und ob's dann klappt, steht in den Sternen (was weiß ich welche Optionen in der FW von Fritzboxen schlummert, die ich hier nicht am Start habe).
Anschließend habe ich die Verbindung mit "ifconfig eth1 add <neue IP-Adresse> netmask 255.255.255.0 up" zum Laufen gebracht. Grundsätzlich funktioniert das USB-Netzwerk jetzt - ob das auch gut ist, muss sich erst noch herausstellen.

Das ganze gibt's mit allen Irrungen und Wirrungen sowie vor allem dem nötigen Patch hier (auf Englisch) nachzulesen. Und, wie gesagt: Dort geht es um den spanischen Fork. Ich denke zwar, dass das auch für die original open7x0-FW anwendbar wäre, aber das habe ich ausdrücklich nicht geprüft.

Gruß,

Thomas
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us | open7x0.org Homepage | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication